Data disappeared? BIG PROBLEM [Solved]

Discussion about MagicEdit features, modules, applications, and HowTos.

Data disappeared? BIG PROBLEM [Solved]

Postby kosborn » Fri Feb 22, 2013 10:28 am

I made some changes to the category page (category.html) on iconsafe.free.magicedit.com

All I did was add a paragraph at the beginning of the page. (shown under "What I added" below)

But now it appears that all the default information for <magicrepeat me_name="CategoryPage" me_repeat="yes"> is back, instead of all the detailed data the client has been putting in for months.
http://iconsafe.free.magicedit.com/main ... -detectors

This also means we can't click through to any of the client's product data that he's been putting in for months. Like this product
http://iconsafe.free.magicedit.com/BW-T ... tMax-XT-II
and this product
http://iconsafe.free.magicedit.com/RAE- ... s-PGM-1860

This is a huge problem. Please tell me you have the data somewhere????

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
What I added:
<BR CLEAR="ALL">
<div class="normal">
<magicedit me_name="CategoryPage-Description">
Class aptent taciti sociosqu ad litora torquent per conubia nostra, per inceptos hymenaeos. Nullam turpis enim, scelerisque ultricies, blandit vel, ullamcorper nec, risus. Nullam fringilla quam sit amet neque. Etiam consequat. Duis imperdiet tincidunt velit. Sed elementum rutrum justo. Aenean ornare tempus wisi. Sed orci. Nulla quis mauris. Nullam condimentum lacinia ligula.<BR><BR>Morbi dapibus wisi vel justo laoreet laoreet. Maecenas fringilla, dolor nec feugiat mattis, metus velit pellentesque ligula, quis posuere wisi erat eu turpis. Phasellus in eros. Aliquam varius varius est. Sed eleifend euismod urna. Nunc in mauris. Cum sociis natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus. Sed dignissim pede ut ligula.
</magicedit>
</div>
kosborn
 
Posts: 77
Joined: Wed Sep 14, 2011 2:02 pm

Re: Data disappeared? BIG PROBLEM

Postby kosborn » Fri Feb 22, 2013 10:34 am

By the way, I haven't worked on this site for several weeks. I don't know for sure if the data was already missing before I made my changes to the category page. If something else happened in the past since the last time I visited the site. I can tell you that the links I provided on my last post used to have products on them, an there was A LOT more data the client has entered for products on all the category pages. I am hoping you can find all that data no matter how long ago it disappeared & bring it back. As well as figure out how to prevent the data from being erased again. Crossing my fingers you can help/ Thanks
kosborn
 
Posts: 77
Joined: Wed Sep 14, 2011 2:02 pm

Re: Data disappeared? BIG PROBLEM

Postby raw10 » Fri Feb 22, 2013 11:14 am

As discussed on the phone, here are the steps we are taking:

1. Restore the site from the daily system backup [edit] COMPLETE
2. Review the causes and see if there is a way to prevent this going forward

The issue is that there was an inadvertent tag mismatch in the saved file that caused MagicEdit to think that the MagicRepeat containing the product data was no longer in the site. The system "cleaned up" after itself since it believed that the data was no longer in use, and when the tag mismatch was resolved then there was no longer any data in the database to display.

NOTE TO DEVELOPERS: Always take a snapshot before making edits to the HTML of a site, particularly if that site has been extensively edited. We can often restore a site (for a fee) from our tape backups if there is an issue, but please do not depend on this as a solution. It can be costly and time consuming to resolve.
raw10
 
Posts: 81
Joined: Tue Apr 12, 2011 2:46 pm

Re: Data disappeared? BIG PROBLEM [Solved]

Postby kosborn » Thu Feb 28, 2013 1:08 pm

Hi

The data on the site just disappeared again. And, I know exactly what I was doing and I know that I did not save the file with a missing magicedit tag. I change, on menu.html

THIS
<li class="main"><span><magicedit me_name="CategoryHeading" me_plain>Category Head</magicedit></span>

to THIS

<li class="main"><a href="#"><span><magicedit me_name="CategoryHeading" me_plain>Category Head</magicedit></a></span>

~~~~~~~~~~~
Nothing extremely suspicious with that. I have no idea why it would delete the data for this reason. This is a problem!!

Luckily I literally *just* made a snapshot. So I will see if I can figure out how to go in & restore it.
kosborn
 
Posts: 77
Joined: Wed Sep 14, 2011 2:02 pm

Re: Data disappeared? BIG PROBLEM [Solved]

Postby kosborn » Thu Feb 28, 2013 1:40 pm

I wonder if the file is not saving completely or something, so when I reload it is got impartial code?
kosborn
 
Posts: 77
Joined: Wed Sep 14, 2011 2:02 pm

Re: Data disappeared? BIG PROBLEM [Solved]

Postby raw10 » Thu Feb 28, 2013 2:42 pm

That is very odd. We will take a look at it and try to reproduce the issue. Your replacement code also has tags mismatched, so it could conceivably be the same problem.

Code: Select all
<li class="main"><a href="#"><span><magicedit me_name="CategoryHeading" me_plain>Category Head</magicedit></a></span>


Should be...

Code: Select all
<li class="main"><a href="#"><span><magicedit me_name="CategoryHeading" me_plain>Category Head</magicedit></span></a>


Or something like that, depending on your requirements. There is another way to insure against this issue, and that is to create a site map file that lists all of the pages on the site. Your MagicRepeat regions, categories, and products could all be visible on that one page, and then if there are issues on other pages you won't end up with the system thinking the MagicRepeat is no longer in use.
raw10
 
Posts: 81
Joined: Tue Apr 12, 2011 2:46 pm


Return to MagicEdit Discusson

Who is online

Users browsing this forum: No registered users and 1 guest

cron